CCCUK logo

 Lancaster Insurance

Website Control

Recent threads

New Forum Posts

» Spare wheel kit 74 by BertieGas on Mon 16 Jul 18 23:40

» Vulcan Tour 2018 by Wacjac on Mon 16 Jul 18 20:03

» Developing Starter Issue by kentvette on Mon 16 Jul 18 18:41

» Shooting for 1000whp with my C7 @ Top Cats Racing by roppa440 on Mon 16 Jul 18 15:07

» Black '68 by Jan25 on Mon 16 Jul 18 10:23

» What did you do with your Vette today? by roppa440 on Mon 16 Jul 18 09:39

» Garage services required for a C3 in the NW by Daytona Vette on Sun 15 Jul 18 20:06

» NEC Classic Car Show - Birmingham by 86vetteman on Sat 14 Jul 18 22:39

» C4 coupe wanted by Redridge Corvette on Sat 14 Jul 18 21:54

» Corvette-Fame 13-14-15 July 2018 by Rich on Sat 14 Jul 18 18:11

»  by Nosheruk on Sat 14 Jul 18 17:44

» How to post a photo in the forums by Nosheruk on Sat 14 Jul 18 17:38

» Looking for a C6 Z06 by BlackZeD on Sat 14 Jul 18 15:47

» New member, new c3 on order! by Forrest Gump on Sat 14 Jul 18 12:06

» C5 seat refurbishment by roscobbc on Sat 14 Jul 18 09:29

» Classic + Vintage Vehicle Festival - Peterborough by curious bystander on Fri 13 Jul 18 17:35

» R/H door lock mech and clip by MIT on Fri 13 Jul 18 16:53

» What modern spark plugs for 1973 454? by roscobbc on Fri 13 Jul 18 00:43

» Insurance by MIT on Thu 12 Jul 18 21:44

» Buying a C6 Convertible.... Or more likely a Targa Top by chevrolet on Thu 12 Jul 18 21:28

» Modified C5 for Sale by Sinatra21 on Thu 12 Jul 18 11:49

» Electronic ign or new bushes by Nigelcurry on Thu 12 Jul 18 08:01

» Rockauto by weslp00 on Wed 11 Jul 18 23:30

» Kop Hill Climb Festival by roscobbc on Wed 11 Jul 18 21:38

» CCCUK Corvette Nationals pictures 2018 by JonnyC4 on Wed 11 Jul 18 18:42

» Ian Goss? by BlackZeD on Wed 11 Jul 18 08:43

» CCCUK West Sussex July meeting by Sea5 on Wed 11 Jul 18 08:26

» Exhaust too loud. by MIT on Wed 11 Jul 18 03:35

» 1960 C1 steering box by paj66 on Tue 10 Jul 18 16:03

» South Central Regional Meeting for July by Bowler on Tue 10 Jul 18 14:48

1993 Cutting Out


Go to page: 1, 2 / Next


Reply to topic
View previous topicEmail to a FriendPrinter FriendlyView next topic

Author

Message

voguev8

Regular

Thu 12 Apr 18 12:55

1993 Cutting Out


Afternoon.
Any thoughts please.
My LT1 has been off the road for the winter, it has had new injectors/fuel pump/water pump and opti.

Now weather is a bit better I have started to use but have found when engine warms up it sometimes just cuts out ( You can be driving along then just stalls ). Will restart after about 10 minutes then fine, does not always happen but around 50% of the time.

From previous experience I would look at the Opti but has only been fitted last month (previous one went bad) and done 100 miles since ( New waterpump is dry and no leaks/drips from front of engine). Any other thoughts before I have to get another Opti

Thanks

Reply with quote

Redlevel

Club Member

Thu 12 Apr 18 13:28

Re: 1993 Cutting Out


Sounds like a dodgy Opti.. The electronics are heating up and failing, then ok again when they cool down.

My '87 did the same although it doesn't have an Opti. In my case it was the HEI chip in the distributor that was failing when it got hot. Similar symptoms.

Reply with quote

Vetteheadtony

Club Member

Thu 12 Apr 18 19:41

Re: 1993 Cutting Out


I with Steve, dodgy module in the optispark


--------------------
Vetteheadtony
2004 Z06 lemans edition pro charged
613 BHP
Black C6 ZR1 wheels
FECKING FAST!!!

Reply with quote

JEI

Club Member

Fri 13 Apr 18 11:29

Re: 1993 Cutting Out


Sorry to hear of your cutting out issue.

To add to previous comments I thought I would document similar issues experienced with my 92 in the past. It turns out I had two seperate causes (didn't occur at the same time!).

First off, to help point you in the right direction: I would suggest checking for fault codes using the paper clip method. If you don't already know, your 93 has a very handy diagnostic mode that spits out fault codes on the LCD display. This is probably discussed elsewhere on this forum. Google should help here too. Failing that, give me a shout and I can give further guidance.

My first case:
The cause was a failing optispark (MSD). Everything seemed fine and then the engine would immediately switch off without warning. Quite dangerous if you are in the fast lane on a dual-carriageway! Wait a few minutes for it to cool and the engine would start again without issue.
It would cut out quite frequently but only once set a code 36 on module 4: ECM (Optispark high resolution).
Incidentally (after running through checking procedures within the service manual to confirm the issue) I replaced with another new MSD optispark. Worked absolutely great for 5000 miles and then it started doing the very same thing! I guess I got unlucky although reading forums in the states, others have reported similar issues.

There now seems to be a consensus that the optical sensors have to be top notch with a belief that the original Mitsubishi sensor utilised by GM/Delphi originally, actually being quite good (as long as it hasn't had a bath in coolant/oil).
I went back to using my original GM unit refreshed with a new cap and rotor and touch wood I've had no further issues.


Second case:
I had another similar cutting out issue with no warning although this time no codes were being set. This made it significantly harder to diagnose. After quite a long time learning the pattern of failure, it turned out to be a failing ICM module. This is bolted to the front of the passenger side cylinder head (by the ignition coil) and as such is subjected to quite a bit of heat. In my case the cut out would occur when the coolant got to a particular temperature. The eureka moment was when I used a block of brass, that had been in the freezer, and placed on the module immediately as the car cut out. With the module cooled, the engine would restart immediately. Without using the brass it would take 10 minutes or so before I could restart. I replaced the module and implemented a common place modification in the US to space the module and it's heatsink away from the head using some washers. No problems since!


I guess a morale of this story: it's not always the optispark (although quite likely!) +use the fault codes to guide you.

Hope this helps. Let me know if you need any further help!

Cheers,
Jonathan


--------------------
Member #3951
92 Corvette LT1, Black
81 Delorean

Reply with quote

FranV8

Awww... join the CCCUK!

Fri 13 Apr 18 15:33


Thanks Jonathan, might apply the mod myself. Interesting the optispark diagnosis comes from two people who don't have LT1's or 4's...

I think I saw your car in St Ives Shell station the other week, good to see it out and about!


--------------------
1995 Corvette LT1 6-Speed Coupe
2007 Honda UFO

Previous
1986 Corvette Z51 Coupe

Reply with quote

Redlevel

Club Member

Fri 13 Apr 18 20:36


FranV8 wrote (View Post):Interesting the optispark diagnosis comes from two people who don't have LT1's or 4's...


Why's that then Fran?

Reply with quote

voguev8

Regular

Fri 13 Apr 18 20:50

Re: 1993 Cutting Out


Thanks for replies.

No codes stored.

Been reading various forums and may point to ICM but anyone know where to get a replacement. Looked at usual suppliers (Ecklers/Summit etc) and cannot find one.

Thanks

Reply with quote

Redlevel

Club Member

Fri 13 Apr 18 21:47

Re: 1993 Cutting Out


Rockauto to the rescue! Just checked and they have several..

Good luck.. Thumbs up

Reply with quote

voguev8

Regular

Sun 15 Apr 18 09:57

Re: 1993 Cutting Out


Thanks,

On order. Hope this sorts as the hot starting is now 50/50

Reply with quote

voguev8

Regular

Fri 20 Apr 18 18:40

Re: 1993 Cutting Out


Replaced the ICM and still cuts out when hot. Wait 10 minutes then it starts again.

I suppose I am going to have to replace the Opti again.

In the states MSD seems to be the best with fewer failures but seems to cost close on 600.

Any other options/recommendations that maybe a bit cheaper

Reply with quote

Reply to topic
View previous topicEmail to a FriendPrinter FriendlyPrivate MessengerView next topic

Go to page: 1, 2 / Next


Permissions

You cannot post new threads in this forum
You cannot reply to threads in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot add events in this forum
You cannot attach files in this forum
You cannot download files in this forum