CCCUK logo

 ShipMyCar.co.uk

Website Control

Recent threads

New Forum Posts

» Amazing by FelixP on Wed 19 Sep 18 14:31

» What did you do with your Vette today? by FelixP on Wed 19 Sep 18 13:44

» Potential new C5 owner - some basic questions by Le Vette on Tue 18 Sep 18 14:09

» Stunt Driving from 1966 Chevys by Daytona Vette on Tue 18 Sep 18 10:47

» 1966 C2 Corvette Wilwood Master Cylinder by L88 on Mon 17 Sep 18 11:44

» C2 fibreglassing and stuff by L88 on Sun 16 Sep 18 16:15

» Euro to US tail lights help by julian marshall on Sun 16 Sep 18 11:41

» Mid engined Corvette by Norm on Sat 15 Sep 18 15:19

» C3 Side Exhaust Pipes by CaptainK on Fri 14 Sep 18 13:10

» Presume this is my battery on the way out? :-( by roppa440 on Fri 14 Sep 18 00:02

» [Pics] C6 Corvette's in the UK. by autocolor on Thu 13 Sep 18 19:45

» Resto Vette - or - Modifed Vette by Vetteheadtony on Thu 13 Sep 18 14:16

» T-tops - single / double latch by Vetteheadtony on Thu 13 Sep 18 14:06

» Breakfast meet by VetteWeekend on Wed 12 Sep 18 20:20

» Recommended Restorers by CaptainK on Wed 12 Sep 18 12:12

» 1990 L98 C4 not starting by lovejoy on Tue 11 Sep 18 19:28

» CCCUK West Sussex meeting in September by robbiew on Tue 11 Sep 18 18:34

» South Central Regional Meeting for September by Daytona Vette on Mon 10 Sep 18 12:22

» Spare wheel light by fordpop52 on Mon 10 Sep 18 07:14

» My 01 c5 yellow for sale by Celcius on Sun 09 Sep 18 20:58

» For Sale 09 C6 Corvette by John Lynn on Sun 09 Sep 18 01:25

» C2 Bonnets by L88 on Sat 08 Sep 18 22:56

» BBCN Regional meet by autocolor on Sat 08 Sep 18 09:48

» Interesting Article by philv8 on Fri 07 Sep 18 23:54

» Heads/cam by Fraser on Fri 07 Sep 18 16:26

» Carburettor leaking by Genghis on Fri 07 Sep 18 14:43

» z51 to z06 by The Dark Knight on Fri 07 Sep 18 08:21

» End of an Era by Firepit on Thu 06 Sep 18 23:39

» Sharing the joy! by Invetterate on Thu 06 Sep 18 21:14

» Seatbelt refurb by curious bystander on Thu 06 Sep 18 20:32

1990 L98 C4 not starting


Go to page: Previous / 1, 2


Reply to topic
View previous topicEmail to a FriendPrinter FriendlyView next topic

Author

Message

lovejoy

Regular

Tue 11 Sep 18 19:28

Re: 1990 L98 C4 not starting - NOW OK !!


Update on "no start" problem.... I took a break for two weeks, with

battery disconnected, when I returned, I re-connected battery terminal,

same problem, fans, A/C clutch, EGR solenoid, and SES light cycling

on and off every two seconds.....

Having re read the GM 1990 FSM, and another GM fault finding bible

(Electrical Diagnosis Service Manual Supplement), I tried the highly

recommended "wiggle test" on all connectors and sensors, with the

ignition "ON", and found a poor connection on the Manifold Absolute

Pressure (MAP) sensor, - - - B I N G O - - - all the clicking stuff ceased !

Rotated key to "start", it fired up and ran immediately.

So I drove the vette out of the garage, and saw, in the pit beneath,

ONE DEAD MOUSE.

Now I wonder what damage he has done before he fell in there ??

Might explain why my blower fan is now on full, all the time, even

with the ign off and key out......

So for now, I just unplugged the blower fan (right offside rear in

engine compartment). I can live without the fan for the moment.


Aren't C4's fun eh, what a challenge !! I hope this helps someone

else in the future..... ( to be continued Smile )



Last edited by lovejoy on Tue 11 Sep 18 20:08; edited 1 time in total. [1 %]
--------------------
1990 L98 C4 vert
white + red sports leather

Reply with quote

Reply to topic
View previous topicEmail to a FriendPrinter FriendlyPrivate MessengerView next topic

Go to page: Previous / 1, 2


Permissions

You cannot post new threads in this forum
You cannot reply to threads in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot add events in this forum
You cannot attach files in this forum
You cannot download files in this forum